April 9, 2009

Linux \ Solaris Interview Question -15

Question 351) Siva wants to backup his home directory Monday-Friday,
which cron job will do this ?
a 0 4 * * 2-6 tar cf /dev/rmt/0 /home/homer
b 0 4 * * 1-5 tar cf /dev/rmt/0 /home/homer
c 0 4 * 1-5 * tar cf /dev/rmt/0 /home/homer
d 0 4 * 1-30 * tar cf /dev/rmt/0 /home/homer

Ans: b


Question 352) Write down the commands at OK prompt to (a find out whether the system will automatically boot to CDE/OpenWindow upon reboot
a ok printenv auto-boot?
b ok env auto-boot?
c ok test auto-boot?

Ans: a

Question 353) Set the corresponding environment variable such that the system will not automatically boot up into the login manager
a ok setenv auto-boot? false
b ok env auto-boot? false
c ok set auto-boot? false

Ans: a

Question 354) Make the previous change persists
a ok default
b ok reset
c ok orginall-conf

Ans: b

Question 355) Which commands in vi place you in insert mode from command mode?
a i
b a
c A
d cw
e D
f G

Ans: a,b,c,d


Question 356) Write down the command to boot a SPARC machine into Single user mode with a CDROM
a ok boot cdrom -s
b ok boot cdrom -i
c ok boot cdrom

Ans: a

Question 357) Softwares distributed as packages on a Solaris 2.x system should contain
a the readmetxt file
b files describing that particular package
c the actual files to be installed
d scripts that should be run before and after installation
e scripts that should be run during removal

Ans: b,c,d,e

Question 358) Which of the following commands will display all packages
a pkginfo
b shpkg
c showpkg
d sh package

Ans: a

Question 359) What does /dev/dsk/c0t3d0s6 identify?
a The logical raw device addressed as Controller 0 Target 3 Disk 0 Partition 6
b The logical block device addressed as Controller 0 Target 3 Disk 0 Partition 6
c The physical raw device addressed as Controller 0 Target 3 Disk 0 Partition 6
d The physical block device addressed as Controller 0 Target 3 Disk 0 Partition 6

Ans: b

Question 360) cp a b report, What does report mean?
a a file
b an option
c a directory
d a user name

Ans: c

Question 361) Which of the following commands are wrong
a pkgrm -d package_name
b pkgrm package_name
c pkgrm -d package_path package_name
d pkgadd -d package_path package_name
e pkgchk -d package path

Ans: a,c,e

Question 362) What is the file (giving its full path) that is modified by pkgadd and pkgrm and contains the listing of all packages installed on a system?
a /var/sadm/spool/contents
b /var/sadm/install/contents
c /var/adm/spool

Ans: b


Question 363) The package command information could be obtained from
a package_path/package_name/pkgmap
b package_path/package_name/pkgcom
c package_path/package_name/info
d package_path/package_name/commands
e package_path/package_name/script
f package_path/package_name/pkgscript

Ans: a


Question 364) What is the correct format of crontab file ?
a time, date, command
b time, owner, command

Ans: a

Question 365) What is the spooling directory used when the following command is issued
# pkgadd -d package_path -s spool package_name
a /var/spool/pkg
b /var/sadm
c /var/spool/dir

Ans: a

Question 366) Packages can be removed from the spooling directory with which command below
a pkgadd -r spooling_path package_name
b pkgrm -s spooling_path package_name
c pkgrm -s package_name
d pkgrm -r package_name

Ans: b

Question 367) When does this job remove all core files ?
0 2 3 * 1 find /-name core -exec rm { }
a runs Monday at 200 am
b runs Sunday at 200am
c runs Monday at two minutes after midnight
d runs Sunday at two minutes after midnight

Ans: a

Question 368) Which of the following directories store the historical information about the patches installed in a system
a /etc/sadm/patches
b /opt/patch/log
c /var/sadm/patch
d /var/sadm/install
e /etc/install/patch

Ans: c

Question 367) Under which dir you can find the path_to_instance file
a /usr
b /root
c /etc
d /var

Ans: c

Question 368) Which is initialization file for Bourne shell
a .profile
b profile
c login

Ans: b

Question 369) When you log into C-shell which file is read
a .login
b local.login
c profile

Ans: c

Question 370) Which of the following commands can be used to display tha patches information
a patchadd -d
b patchadd -p
c patchadd -i
d patchrm -i
e patchinfo
f showrev -p

Ans: b,f

Question 371) Consider the following
# cp /etc/rc2.d/S22mylp /etc/rc2.d/.S22mylp.orig
a There is a problem, because init will execute both run control files at startup.
b There is a problem, because init will get confused and fail to run at startup.
c This is not a problem, because S22mylp and .S22mylp.orig will cancel each other out when init executes both files at startup.
d This is not a problem, because .S22mylp.orig will not be executed by init at all at startup.

Ans: d

Question 372) What if the /var/sadm/patch directory is tempered
a the patches added to a system may not function properly
b the system will crash more frequently
c the patches cannot be uninstalled
d it will not affect the system at all

Ans: c

Question 373) Which of the following cannot be configured through admintool
a users
b groups
c hosts
d printers
e parallel ports
f serial ports
g software

Ans: e

Question 374) Which is the preferred method to temporarily prevent a user account from being used?
a Delete the user account and all files in the home directory of the user account
b Lock the account using admintool
c Modify the user account .profile to change the user environment
d Use admintool to change the UID and GID associated with the user account

Ans: b

Question 375) A patch obtained from Sun Microsystems can be installed using which of the following commands?
a pkgadd -patch 107588-01
b patchadd 107588-01
c patchadd /var/spool/patch/107588-01
d patch SUNWaccu 107588-01

Ans: b,d

No comments:

Post a Comment